Losing connection

I’ve setup TVersity to share photos from a computer to my HR20. It works well for a minute or two and then craps out. Seems like it’s losing connection with the servier.

I’m on a wireless connection (I know a wired would be better) but I need to know if there’s a way to change the “time-out” setting so it will keep trying when it loses the connection for whatever reason.

DirecTV VOD works fine (altho’ it’s slow…) so I would think the connection would be good enuff for serving photos.

Any thoughts?

I’m pretty sure thats a HR20 software problem, not tversity problem.
It’s not “losing connection”.

Like you said, I suspect it’s the “timeout period” they hardcoded into the hr20 software for how long it should take to access each file before it will give up.

Happens to me a lot on my 2.4GHz laptop.
It’s quite aggrivating.
I pray they raise that timeout period.

So you’re saying that you have the same problem even with a hardwired connection? I was going to try running a cable but I don’t wanna bother if it won’t fix the problem…

No, I didn’t say I’m hardwired. My hr20 is hardwired and my laptop is wireless. But the problem definately isn’t my laptop losing it’s connection. The only time I lose laptop’s network connection is when I disconnect it. This is easily verified when I check the connection’s duration time.

:wink:

The problem is the HR20’s timeout setting.

Want circumstantial evidence? Set up WMP11 so it can share your pictures to HR20. Bet it will work perfectly, as it does for me, never misses a picture even when doing a “shuffle all” for your pictures.

So why does the problem only happen when you use some other media player like TVersity? Probably because we have TVersity set to “ALWAYS TRANSCODE” all media formats and to resize image & video formats. The amount of time it takes to transcode/resize is probably “just enough” to cause HR20 timeout problems when attempting to access the files.

Least that’s what “I” believe.

I wasn’t able to get WMP11 to work with my setup - that’s why I tried TVersity in the first place.

I made some changes to the transcoding options and will try it again.

I also ordered a 100 ft Cat6 cable to try. I’d rather not have to install that, tho’, if I can get it working well wirelessly…

Have you ever tried hard-wiring your laptop to the network just to see if it works better?

No, because my common sense tells me 54 Mbps wireless probably isn’t a “bottleneck” when we’re talking about loading pictures.

And like I said, I’ve had WMP11 sharing pictures to HR20 for probably 6 months or so, and it never experienced this problem. The problem for me didn’t begin until I got TVersity rolling, which is what introduced “transcoding” to the mix.

The real key to all of this is what I said earlier about how my WIRELESS laptop NEVER loses it’s connection to router … and since my HR20 is WIRED, I can’t see that losing it’s connection while the laptop keeps it.

So since I’m not “losing connection”, then logic as a programmer tells me it’s got to be a “timeout” setting that provokes the HR20 to display the “nag” onscreen saying it can’t access the file.

And EVEN IF it’s the 54 Mbps that is causing the timeout, that’s a problem with the TIMEOUT being set TOO LOW in the HR20 software, which should be very easy for them to change.

Give the DBSTalk gang some time to let DirecTV know this is becoming a serious problem, and I’m sure DirecTV will address it sooner or later. Only trouble is I wouldn’t expect them to fix it super-soon. They have a tendancy to stick to their current agenda of what to fix and get to the new requests “down the road”.

I’ll start up a new thread there today about this.

:wink:

Did you ever get any love on the DBSTalk forums?

I was thinking about trying to resize my photos. Have you tried this? I wonder if the hi-rez photos are contributing to the problem…

Screw it. I resized a directory full of photos (only about 12) to 1024 pix wide and the stoopid thing still hangs up.

I’m done messing with it. Not worth the headache.

Maybe D-TV will let me know if they ever come up with something that just works…

Dude, lighten up.
Mediashare is still beta for DirecTV.

I do have a thread on this topic.
Yes, it got replies.
It does appear to be a timeout issue.
I expect that we will see this addressed in a future software release.

:wink:

Dude, you mis-read my mood. (probably my fault).

I understand it’s beta stuff. That’s why I’m willing to throw in the towel until things get a little better defined.

I’ll probably mess with it again from time to time but it’s not worth spending a lot of time and energy on it right now.

Maybe someday the DirecTV box will be a PC that we can just copy files to and it will play them instead of having to do all this media sharing stuff.

Thanks for the help.

If you don’t mind, could you give me a link to the thread you started on DBSTalk? I couldn’t find it and I’d be interested in the comments you received.

Thanks.

http://www.dbstalk.com/showthread.php?t=121388

And that link was definately seen by at least one high ranking directv employee.

:wink:

If it’s not fixed in tonights CE release, I plan to begin noting this in the “issues thread”, which is the next step after determining if a bug is limited to one user or more widespread.

I think when the codec pack tried to install it failed. Yesterday I did it and it failed then I repeated it and it worked…

Now the itunes non DRM files are playing on my computer so I expect and hope they will play on the HR20 DVR too…

Thank you so much for your help!