Tversity Cannot Be Seen In Windows 10

Hi All,

I have just done a clean install of Windows 10 Pro x64. I have downloaded and installed Tversity 3.8 and although the program runs fine as a service, I am unable to see it on my media player. This setup worked perfectly under Windows 8.1 Pro x64 so it must be some sort of incompatibility in Windows 10. I am just wondering if anyone else has experienced this issue?

I have ensured that its not a Windows Firewall issue as I have disabled Windows Firewall to test. Still not visible. Have even rebooted just to ensure that it was starting up correctly.


1 Like

You need to run “windows firewall with advanced security” (i.e. just the config tool in Windows) and add port 41952 as allowed. That is the only problem I had getting it working.

Oh disable firewall doesn`t actually help! that is what I also tried first :smile:

N.B… also I need to specifically set the IP address in the TVersity settings for my host address. I didn`t mention that before as that has always happened in all previous OS and TV version… guess it is a network adaptor order type thing and is nothing (specifically) Win10 related.

@ PaulM, were you able to transcode videos (Tversity Pro 3.8)? Server Messages showing “Error - Could not run graph”.

If I force it to transcode always then yes it works (I don`t actually need the transcode for my TV but did try it via forced setting). I guess it depends on what codec packs you have installed… I use ffdshow still.

My only Win10 issue (as slightly different): I am getting a lot of buffering for some reason on the client end, have not worked out what is causing that, could be something on the network driver or firewall. Will figure it out eventually :smile:


Did it work for you? As an unpaid/unaffiliated chap who just wanted to help out would be nice to know. I had to register an account just to share the experience

N.B. Worked out my buffering issues and turned out to be the switch just needed a reboot, simple things…

@PaulM thanks for taking the time to assist other users.

Transcoding still does not work for my Xbox 360, I’ll some how figure it out.


I suggest uninstalling all codec packs and then installing just ffdshow and then TVersity.

Do I also need to re-install the matroska splitter?

No, just reinstall TVersity. If some MKV files do not transcode, then you can consider adding other splitters, but I would leave it out for now.

There was no issue with port configuration in windows firewall. Adding the local ip adress (not the one that appear in tversity setup, but the one that appear in details of wifi status ) solved this issue. But here’s the next issue: if my computer restart and change local ip… i will need to change tversity setup. Maybe tversity should also add local ip as an automatic listening ip adress…

The simple solution for that is to make sure the network adapter associated with the local ip address is the default one in Windows – You do it by changing the binding order of those adapters. This issue is not unique to Windows 10 and e.g. also exists in Windows 7. More info at:

Thanks, that’s seem to work correctly now.