Tversity - Making it Work for PS3 *updated 11/23/09

[quote=“KarnaG3”]
PLEASE DO NOT FOLLOW THESE INSTRUCTIONS, AS THEY COULD CAUSE YOU SOME HEADACHES
But thanks for the props :)

I have already covered this logon issue in the guide.

Its under the section clearly labled:

[size=150]TVERSITY WINDOWS LOGON ISSUES (aka the Tversity services.msc issue)*[/size]

The process outlined by this user is NOT necessary, and even creating the logon should NOT be necessary.

I have also already covered the issue with the SSDP/WMP Sharing/ UPnP.

The newest version of Tversity makes these changes (or gives the option to have Tversity do it for you, I believe) automatically.
DO NOT DISABLE SSDP. This may work for this user, but it will likely cause DLNA errors.

The UPnP service is replaced by the Tversity Server and this now handles the UPnP fuction & Tversity function.

It appears that if you had this issue you may not be using the newest version of Tversity, or you aren’t using Vista, OR you have Vista User Account Control on (the single most annoying thing Micro$haft has ever conceived).[/quote]

yes the TVersity services issue is described the only problem is that when I tried to set the service to log on as myself…it would give me a log on failure error, which is why I had to do the whole workaround in local policies. I assume most people wont run into this issue and will just be able to set the service to log on as themselves…but not for me…and yes I am using old TVersity …RC4 to be exact (i didnt want to void my KarnaG3 warranty :lol: )

I am using Vista and I do have UAC turned off it was a problem with local policies…technically the service was allowed to log in as me (Administrators group was added) but for some reason it didnt listen, so I had to add myself to the allowed list (I am in administrator group anyway).

as far as SSDP…i usually shut off most of services and turn them on when I need them ;)

btw creating a separate log on for the TVersity service is not only unnecessary but it will also NOT WORK. The service HAS to log on as the same user that installed ffdshow.

I have noticed some things today when using a MKV prison break as a testfile.

I tried cleaning the temp folder inbetween every test, so to be sure TVersity doesnt get anything from cache.

I played the same MKV file in two ways, wireless and wired. In both cases I have though choosen the best settings, no compression, no decrease bitrate and 100Mbps hardwired with best signal.

I played the whole video for 40min on wired, and that worked completely without any stutter at any point. The resolution is setup as 1280x720 (720p) and the MKV file is also in 720p.
But when i played it wirelessly (54g network, router and PS3 in same room only a couple of meters from each other) it stuttered a couple of times, although not like that completely so it was unwatchable, on the contrary it happened amaybe 5 stuttering moments.

Now, the following observations have been made.

  1. Almost every time when the video stutters for 2-3 s TVersity status changes from transcoding active to suspended. Any corelations here maybe?

  2. It stutters at exactly the same point in the video every time I play it wirelessly, so its not that much random actually.

and last but absolutely not least, which in fact confused me

  1. my CPU reports (dual core AMD) that both cores are almost constantly between 90-100%.

This surprised me, because when just switching from wireless to wired 100Mbit ethernet and play the video again the CPU load on both cares are at max 25%!

Anyone with any explanations?

I’m sorry if someone posted this before, but is your link to FFDShow suppose to go directly to a download link? I found it after clicking that link and found that the newest FFDShow is 11/26/08 here http://www.free-codecs.com/FFDShow_download.htm but do i get MMX or SSE? or are they even different?

KarnaG3…your instructions helped me out tremendously. I went from not being able to stream regular divx avi files to being able to watch MKV on my Xbox360. I know these instructions are for PS3…but most of the settings are done on PC regardless of your console (given that you console can see Tversity server already).

I figured maybe this may help someone else out there.
DISCLAIMER: Please follow original instructions. These are just steps I personally took to make it work for me, but I followed original instructions from the beginning.

Okay so this is what I did. I did not know which Codec’s I had installed on my machine…so I went into Add Remove Programs and uninstalled everything that said Codec and anything that had to do with video or audio (ie.: i uninstalled Quicktime, Real Player, AC3, DivX Player, Orbin .ogg and Matroska (while I was here I uninstalled other programs I didnt use :))). I then uninstalled TVersity RC5 and deleted the Tversity folder in Program Files. Reboot and run Registry Mechanic and reboot once again.

From here I followed ORIGINAL INSTRUCTIONS. First I got everything I needed. I downloaded TVersity RC4 (not RC5…I dunno why…but I didnt want to risk it), I then downloaded FDShow from the link given, I checked my processor on Newegg and noticed that it supports MMX so I got that FDShow MMX 11/26/2008. Then I downloaded Matroska also from the link given. THATS IT. NO AC3 NO DIVX NOTHING…did not download any of those.

I first installed FDShow and left all of the default settings, except I checked off subtitle setting…but thats it. I then installed Matroska. REBOOT. Then Installed TVersity RC4 and when it came to installing TVersity Codec Pack I unchecked it and did not install it. I then added some simple AVI to my library as well as MKV.

On my PC I turned the following services to Either Manual or Disabled…it shouldnt matter as long as they are not running.
Internet Connection Sharing (ICS) - Disabled
SSDP Discovery - Disabled -this will also turn off Windows Media Extender service as it is dependent on SSDP
UPnP Device Host - Manual
Windows Media Player Network Sharing Service - Disabled

Thats it. I launched XBOX360 and started with AVI(DivX) first, it went smoothly…already progress. I tried to play MKV and got "Xbox not supported content"…however usually when I get this error my TVersity would crash, but this time it did not crash…it just gave me an error, but the service kept running. Good sign. I went to check the Server Status in TVersity GUI and noticed it said "Could not start transcoding". This means that TVersity service doesnt have the right to transcode the file…meaning I need to change the service Log On As… property to log on as me (administrator) This is already in the original instructions

However once I changed the service property to Log On as administrator I could not restart the service due to a "Log on failure". These are the steps I took to fix it.

  1. Right click on Computer and click Manage.
  2. Expand Event Viewer->Custom Views->Administrative Events.
  3. The latest Error should be your Log on error…double click it and make sure it says "Logon failure: the user has not been granted the requested logon type at this computer."
  4. If this is the case then follow these steps to fix this.
  5. Press Windows Button+R to get into run or just type this in the vista search box gpedit.msc
  6. Expand Computer Configuration->Windows Settings->Security Settings->Local Policies->User Rights Assignment
  7. Find "Log on as service" and double click it.
  8. Click "Add User or Group" and add yourself(type in your full username and press Check Names) or use the same way you would have when you do "Log On As…" for the service.
  9. Now go back to TVersityMediaServer service and restart it under your username. which should also be the account you installed fdshow and matroska under.

This solved my issue and now I could watch MKV on Xbox…however I am still trying to figure out how to display subtitles. lol

DISCLAIMER: PLEASE FOLLOW ORIGINAL INSTRUCTIONS. THESE ARE JUST THE STEPS I TOOK FOR MYSELF. I PUT THIS HERE IN CASE YOU ARE HAVING SOME OF THE SAME ISSUES I HAVE HAD AND THIS MAY GIVE YOU SOME TIPS ON WHAT MIGHT BE THE PROBLEM. BUT I CANT STRESS USING THE ORIGINAL INSTRUCTIONS ENOUGH, WHICH IS WHAT I FOLLOWED UNTIL I RAN INTO SOME OTHER MINOR ISSUES

hope this helps. if you have questions about how i did it, feel free to ask. however i got it to work for XBOX360. which probably shouldn’t be in this thread, but i just wnated to give my thanks to KarnaG3

[quote="joksi"]I have now tried out everything a little bit more, and that leads me to the following questions.

  1. Doesnt PS3 support DTS?? Im trying a MKV with DTS, and FFDshow transcodes (DTS enabled), also Im trying a m2ts muxed file which the PS3 stream without transcoding, with DTS, and in the transcoding scenario PS3 states 2 channel PCM (im getting sound, but not 5.1), and in the no-transcoding scenario PS3 states AVC video but empty sound (no sound at all whatsoever)?

  2. I have ffdshow enabled for AC3, and i have tried streaming MKV to my PS3. This works, however, the sound is only ooutput as 2 channel even though its 5.1 channel in the MKV file. Isnt it possible to stream several channels together with the video to the PS3?

I have also tried .srt subtitles together with MKV and it shows up on the PS3, after activating subtitle support in ffdshow of course.

Also, i recognized that if i set ffdshow to SPDIF output for AC3 and DTS, and play a video on the PC my receiver recognizes AC3 and DTS so i get all channels out from the SPDIF output on the PC. But when I then try streaming to the PS3, MKV just gives me data corrupted. When i switch back to default in ffdshow, not SPDIF, i again hear sound in PS3 (however not 5.1 still) and when I play on the PC video the receiver doesnt recognize AC3 anymore, only 2 channel PCM.

So the question is, how can i make TVersity stream AC3/DTS 5.1 channel sound from my MKVs to the PS3?[/quote]

  1. What is a m2ts muxed file? I am not familiar with this.
  2. YOU MUST MAKE SURE THAT FFDSHOW AUDIO IS CONFIGURED W/THE OUTPUT YOU WANT.
  3. YES, it is possible to stream more than 2.0 surround, but PS3 has to be configured to accept the PCM signals, and to output as such. Check your PS3 audio settings
  4. SPDIF IS IRRELEVANT. You are sending a networked data stream to the PS3 NOT SPDIF. We’re talking RADIO vs. CELL PHONE. Not the same, but similar. Point being: you CAN send [whatever] sound from PC to receiver, but that doesn’t make it “streamable”. The most important thing is #2, FFDshow.

It sounds like you have 2 different codecs handling H.264/MP4 files. My guess is you have ALSO installed Quicktime at some point. Uninstall Quicktime (or whatever that "other" codec in question is) and start from scratch.

Lemme know :)

[quote]

The PS3 only supports DTS on a BluRay, not streaming.

Don’t use ffdshow for AC3. Disable it and use AC3 Filter instead. Of course, thats only if you’re transcoding, which isn’t necessary if you follow this:

viewtopic.php?f=28&t=12570

Had me streaming Transformers with 5.1 AC3 sound in less than fifteen minutes. Its ridiculously simple. Demux the DTS file with tsmuxer, then use DKAudio to make it into AC3. Remux the original video file (in 4.1 profile, of course) with the shiny new AC3. Make sure you mux it as TS. Then enjoy genuine 5.1 sound with any mkv file with DTS.

The files work beautifully, but I have yet to get an HD file to stream to the PS3 without skipping and stuttering. My bandwidth monitor shows it pegging out at 13000 kb/s, but its very erratic. It will shoot up to 13000, then nearly drop out completely and so on. Its almost as if its being governed at a certain threshold. That leads to me to believe that the PS3 can’t handle streams of high bitrate material. I know its not the router, because other times it easily handles 16M+. Is this a PS3 firmware problem? Anyone else able to wirelessly stream mkv files to the PS3 with no problems? I don’t mind copying them over, but large files take awhile since it can’t copy any faster than it streams.[/quote]

DO NOT LISTEN TO THIS PERSON, PLEASE REFER TO THE UPDATED GUIDE (now on page one and page 11 or 10 or whateva) WHICH SPECIFICALLY STATES THAT YOU ****DO NOT NEED AC3 FILTER

*******************************AC3 FILTER IS THE PRIMARY CAUSE OF ISSUES W/AUDIO STREAMING ON MKV FILES. IF YOU USE IT, don’t bother looking in this thread for help…mostly cuz you don’t need it :)

******PER LAST NOTE:

What he DID get right is that DTS is not streamable.

PCM is. If you can tell the difference between the two, you should probably be working in the military, because you’re a freak with superhuman hearing :)

[quote="Corran006"]Ok kids. I followed this guide.

But when I would stream video to my PS3 I would get very poor speed, the video would pause and jump and just be slow to start.

So I got thinking maybe its nothing to do with Codec or Tversity or the Play station 3 at all.

So I look at my network card setting and I notice its set at Force 100 Full Duplex. So I change it to Full Autonegotiation and it works perfectly

Make sure your PS3 is also set to auto.

This is what fixed my Streaming problem.[/quote]

PS3 ??? auto what? very unclear.

PS - Your "duplex" settings should NOT default to 100 Full, as 1/2 duplex is the normal "standard" setting.

This appears to be an issue unique to this user.

If you (or anyone else) can clarify your results, and how you got there, this might be useful.

**Please do NOT note instructions for other users that don’t clarify what the hell you mean, like these. :)

[quote="funkyspunkymonky"]Do you have to have a wired connection to make Tversity work with the PS3? I have a wireless connection with Vista Premium and have tried uninstalling/re-installing and I always get the "Data Corrupted". I have never had Tversity work and I installed it for the first time with 2.50 firmware using these instructions. I also never installed any codecs before Tversity.

Meanwhile, I have gone the Windows Media player route and forced my vista to “see” mp4 files, but the PS3 still can’t see mp4 files thru Vista. Anybody know how to change that? The only HD I’m interested in is from my own recording in Vista. Then I convert to mp4 using Video-9 and all I need is the PS3 to see the mp4 files on my Vista. Any ideas anyone? Thanks![/quote]

Recording in vista? Are you refering to self-produced media?

NO idea what you are talking about here.

  1. DON’T USE MEDIA PLAYER TO STREAM YOUR VIDEO, THEN ASK WHY TVERSITY DOESN’T WORK. A default requirement to make Tversity work is that you DISABLE SHARING IN WMP.

  2. IF you have already started sharing w/WMP, have then DISABLED it, and then used Tversity, you may get a data corrupt message.

The MOST COMMON CAUSE OF DATA CORRUPT MESSAGES is files that are NOT accessable by Tversity because a) you have changed the name of or moved the file or b) you haven’t rebuilt your library since your last Tversity install.

I’d say start from scratch. DO NOT EXPECT TO BE ABLE TO USE BOTH WMP & TVERSITY FOR STREAMING (as it won’t work and is a complete waste of time as Tversity will do all of it for you) and not have problems.

I AM NOT GOING TO TRY TO SUPPORT THIS TYPE OF USE IN THIS THREAD. Stick to the program.

[quote="joksi"][quote="KarnaG3"][quote="joksi"]I have the same problem!

Or, in fact, I can watch everything it seems but not MKV, I just get the data corrupted message and also the PS3 marks the file as MPEG-1?

At the moment im trying the solution with converting from MKV to MP4 with tsMuxer, and then I can stream the video file (with no noticeable difference in quality and takes about 2-3min) directly without transcoding, ie in WMP11 or TVersity too, and the PS3 marks the file as AVC. It seem to work good at 720p, however, why doesnt the embedded subtitle show? When watching on the PC there is subtitles. Any ideas?

Also, on top of everything, the MKVs after givin the corrupted data message, also makes TVersity crash,or better said just switch off the sharing so i need to start sharing again.[/quote]

Ok, seriously, sticko & joski - DID YOU EVEN READ MY UPDATED GUIDE? It specifically says "yes, you only need HAALI splitter* AND FFDSHOW".

You need either Haali or Gabest splitter to use MKV. Period.[/quote]

I think you are so into your own thing, that You actually dont read at all on what your answering.

I have tried several things, and this includer cleaning the registry inbetween.
I have installed Vista Codec Pack, K-Lite Codec Pack, and just FFDshow and Haali OR Gabest separately. In all scenarios I can watch every single MKV file I have available, on my PC in WMP11.

BUT, the issue arises (only) when starting to stream to PS3 and its MKV, data corrupted is the only thing I get and in some scenarios also TVersity traybar icon just gets grayed out (sharing disabled, have to manually start it up again).

The issue with PS3 tagging TVersity files as MPEG1 is specific, cause when I used TVersity in a older release when changing to mpeg2 in the config.xml file all files were transcoded to MPEG2, so the PS3 also showed this. Now it doesnt matter, it always shows MPEG1.[/quote]

  1. DO NOT ASK ME FOR ADVICE AND THEN TELL ME I’M WRONG. It works for me and many others, and obviously not for you. So if you DON’T know the answer, you also can’t tell me I’m wrong. If you don’t want help, go somewhere else if you DO, read on…

  2. Shut up about the FILE TYPE MPEG 1 OR MPEG 2. This is completely irrelevant and I’ve already answered this question…but to go on further with that answer: Tversity has changed, for whatever reason, the file type that is *STREAMED. This is NOT relevant to the originating file type and so is NOT your concern. I can tell you how to change this, but it won’t help. Forget it.

  3. DATA CORRUPT MESSAGES are caused because a) Tversity can’t access the file ( less common, due to folder or file not being shared) b) Tversity and/or codecs have been installed/reinstalled since that file was added to the Tversity Library. This is KEY: THE LIBRARY. If you get a data corrupt message, I suggest clearing your cache in Tversity, rebuilding your library by starting w/deleting existing items in the current library and readding them, and restarting your PC.

  4. IF YOU ARE STILL HAVING AN ISSUE KEEPING TVERSITY RUNNING (i.e. grayed out at random) this means for some reason you have an access problem: either a) Tversity has not been given proper access to said file/folder or b) Tversity has not been given proper logon privileges in windows. See the guide.

The issues you are having tells me you are taking shortcuts and NOT installing codecs from scratch, NOT installing Tversity from scratch and NOT correctly rebuilding your library.

Server programs are VERY touchy because of access rights in Windows and file types, especially when dealing with transcoding.
Start at the beginning of the updated guide (which will be on the first page due to my update once you read this).

Do NOT bitch at me or I will not help you. If you don’t want my help, ask one of the Tversity gurus who programmed it in the first place.

[quote=“matek2305”]Hello! I’m from Poland and I’m new on this forum. Please forgive me my engish :P

I use TVersity for around 3 months and everything works fine but today when i try to start server i get error: “Unable to connect to the Internet” but i can use Firefox, FlashGet etc. which need Internet connections. When i go to the library tab i again get error but now it is : “Unable to connect to the server…”. I cant use TVersity now because of it:( I try thing with uTorrent to disable option from FAQ and it still not work :( I use RC4 version but i try with older and its the same problem. Please help me. matek2305[/quote]

The issue you are having appears to be caused by access rights. You need to follow the instructions (in my guide) for how to add Tversity logon access in System Services.

If this does or does NOT work, let me know.

PS - You’re English is pretty good. Forgive me my Polish :)

[quote] (karnag3 edit): BLAH BLAH BLAH…
I have now uninstalled every single codec on my PC and TVersity, cleaned the registry, rebooted and reinstalled FFDshow tryouts, rebooted, installed Haali mediasplitter, rebooted, installed TVersity without codec pack, rebooted and then setup TVersity. Once again, MKV works great on the PC but corrupted data in the PS3!??[/quote]

Just like I told your twin brother: it appears you have an issue following instructions but…

  1. I’m guessing you installed the Haali splitter AFTER you installed Tversity
  2. If you didn’t… then either a) You need to remove ALL of your files from the Tversity library, clear the cache in Tversity, then re-add all the files in the library but NOT BEFORE YOU DO THIS:
  3. MAKE SURE THE FOLDER YOU HAVE YOUR MKV’S IN IS a) SHARED/not denying access to YOU w/out password, etc and b) is NOT being SHARED BY WMP.

If you have (for some unknown reason) decided to share, or WMP has somehow done it for you, sharing this folder/file in WMP WILL CAUSE THIS ISSUE. This is due to the UPnP server (the one w/windows NOT Tversity) accessing the same file at the same time or "reserving" it so Tversity cannot access it.

Mostly because this is a HUGE WASTE OF TIME and if you have the correct codecs, YOU DON’T NEED TO DO THIS SO PLEASE DON’T LISTEN TO THIS GUY.

[quote="joksi"]Why not then tsMuxer, which i already have used?
It takes 2 minutes, and is supported by PS3 natively.

Although I have great news, i really aint sure why or how, but i did the third uninstall and reinstall, but this time I installed the ffdshow (codec pack) included with TVersity (i know, its one year old ffdshow release, but hey it works thats what counts) and afterwards I installed Haali media splitter. I also rebooted after each install, and know suddenly all my MKVs show streams to the PS3! =S

Still showing up as MPEG1, though.

I really dont know what made it work, however, it seem to work now. Now the question is, should i let ffdshow do AC3/DTS like now or should I disable it and install AC3 filter pack? Its late now, but tomorrow I will continue testing and change one thing in one step at a time, that is AC3 filter, subtitles with ffdshow transcoding (maybe try just replacing ffdshow to newest tryouts?) and foremost subtitles in MKVs (embedded/external).

So, my solution: TVersity WITH included codec pack + Haali media splitter on Windows Vista Business 32-bit. Which seems to work much, much better then the howto’s in this thread regarding MKV playback.[/quote]

Okay, dude last time: (quoting myself) YOU DON’T NEED AC3: THIS IS NOT NECESSARY FOR STREAMING AND IS A HUGE CONTRIBUTOR TO THE “GARBLED SOUND ISSUE”.

Are you stoned when you read this or something? I mean I totally already covered this.

MKV is NOT that complicated. AC3 is NOT needed. If you WANT to use the FFDShow included w/Tversity, cool. but you DON’T need AC3 and you DON’T need to do anything fancy to use embedded subtitles. IF YOU (or file in question) USE EXTERNAL SUBTITLES you simply need to instruct your codec (ffdshow, etc) to use this.

[quote="bigaljp"]Thanks for all the useful info. I set everything up fine and it all went well.

One question though - I was wondering if it is possible to change the Aspect Ratio. I have a normal TV - no widescreen :( - and when I switch to normal mode via the PS3 controller it cuts out the left and right side of the movie. Wide Screen has the big black bands on the top an bottom.

Can I change the picture to fit my screen?

Thanks in advance![/quote]

FFDShow Decoder, under "Resize & aspect", there are all kinds of settings for aspect ratio.

There are also various view settings under the "triangle" on the PS3 when viewing a video. Some of the zoom features work well, but you cannot change the aspect ratio with this option, however it may allow you to see the full picture.

[quote]
i did a full reinstall just as stated ffd then haali then tversity removing my codecs before and restarting and cleaning my reg every time. the file i want to see is and xvid 103 for video, and mp3 for audio. it still keeps coming up unsupported. ffd has the xvid codec enabled and mpc plays the file ive tried reinstalling my library but i cant add files with the service off and i deleted my temporary files. Soo whatd i do wrong here? My other files do transcode now rmvb ect… just not this one[/quote]

  1. IF PS3 SAYS "UNSUPPORTED" this is NOT THE SAME AS "CORRUPT DATA"
  2. This message means that file is NOT being transcoded
  3. Find the folder/file in your Tversity library and set it to "always transcode" under the advanced options.

Just because FFDShow is set to decode this file, does NOT mean Tversity will TRANSCODE that file. If Tversity is set to “as needed” for transcoding, it will NOT, by default, transcode Xvid or DivX because these are [sometimes] natively supported on PS3, therefore [sometimes] don’t require transcoding.

[quote="MasterShake"]

yes the TVersity services issue is described the only problem is that when I tried to set the service to log on as myself…it would give me a log on failure error, which is why I had to do the whole workaround in local policies. I assume most people wont run into this issue and will just be able to set the service to log on as themselves…but not for me…and yes I am using old TVersity …RC4 to be exact (i didnt want to void my KarnaG3 warranty :lol: )

I am using Vista and I do have UAC turned off it was a problem with local policies…technically the service was allowed to log in as me (Administrators group was added) but for some reason it didnt listen, so I had to add myself to the allowed list (I am in administrator group anyway).

as far as SSDP…i usually shut off most of services and turn them on when I need them ;)

btw creating a separate log on for the TVersity service is not only unnecessary but it will also NOT WORK. The service HAS to log on as the same user that installed ffdshow.[/quote]

  1. The 2nd user logon is not something I recommend as I’ve stated previously, but it WILL work if you need it, but most don’t. Single users can ignore this.
  2. The “policies” issue you are having is likely cause by access rights for your particular user name and will NOT affect 99% of the people running Vista as by default the primary user has Admin rights, but you are correct in saying that this is necessary to make the Tversity service logon correct…however… you are did NOT use the easiest way to clear the issue. Updating Admin rights for a user can be done in the User Accounts screen under Control Panel and will easily achieve the same thing. I’m not sure why your access was limited, but hopefully this will help others who might have a similar issue.

*PLEASE NOTE: this issue is relatively uncommon and not likely to be something you [other users] need to address.

PS - Rather than disabling a service if you don’t want it to run, your best option is to set it to “Manual”. Manual will leave the service inactive until needed and if another service/program requires that service that has been set as manual, Windows will start it for you. I DO NOT RECOMMEND DOING THIS UNLESS YOU KNOW WHAT YOU’RE DOING, but in the case of SSDP it would work fine.

I just wanted to say that after following KarnaG3 updated thread WORD FOR WORD, everything is working smoothly for me. The last thing I was trying to get working was 5.1 channel sound from my AC3 encoded files which would NOT work when AC3filter was installed regardless of whether it was enabled or not. After removing all my codecs (including AC3Filter) and Tversity, cleaning the registry with CCleaner, rebooting and following the guide, 5.1 surround is now working perfectly.

The only deviation to the guide is that I’m using a lower max video and image res (though still within the same proportion) since I don’t yet have an HDTV so the higher resolution is giving my computer more work to do when I can’t take advantage of the high resolution.

I’ve also noticed that after using this updated guide, streaming is MUCH faster and buffers less. Could be the latest version of TVersity or less codecs interfering. Regardless I’m quite happy and I suggest that anyone having trouble go back and follow the guide properly!

Thanks again, KarnaG3!

What exactly did you to for 5.1?
I tried installing AC3filter, just because it looked like FFdshow mixer setup wasnt enough. But AC3 filter didnt improve anything.

I still get the same message as with FFdshow alone, "data corrupted", when i set it up to 5.1 channels. Switching back to 2.0 stereo solves the problems, however without any 5.1 channels.