Tversity - Making it Work for PS3 *updated 11/23/09

[quote="joksi"]What exactly did you to for 5.1?
I tried installing AC3filter, just because it looked like FFdshow mixer setup wasnt enough. But AC3 filter didnt improve anything.

I still get the same message as with FFdshow alone, "data corrupted", when i set it up to 5.1 channels. Switching back to 2.0 stereo solves the problems, however without any 5.1 channels.[/quote]

As it has been said many, many, many, many, MANY (ok, you get the picture) times before:

DO NOT INSTALL AC3FILTER!

I have already said that with AC3Filter installed, 5.1 WILL NOT WORK. It doesn’t matter if it’s disabled it still WILL NOT WORK.

If you have installed AC3Filter, you must uninstall TVersity, all codecs, AC3Filter, clean your registry settings AND START OVER.

Seriously, it’s not that hard. Just follow the instructions in the first post and it will work. Here’s the key part:

DO NOT DO ANYTHING DIFFERENT FROM THE INSTRUCTIONS!!!

You might be tempted to change the speaker settings when installing FFDshow from the default 2 channel stereo to 5.1 but DON’T DO IT!!! Don’t even mess with ANYTHING unless it’s in the instructions. Don’t even bother with the mixer in FFDShow. My Mixer settings are still at default which is 2/0/0 but all my AC3 5.1 divx files play with 5.1 surround.

If you don’t follow directions I can’t help you because that’s what I did and it worked just fine.

EDIT: I noticed you’re having problems with MKV and 5.1 Surround. My DivX files that have AC3 5.1 surround will play in 5.1 surround and it will show in the information when I press the Select button. My MKV files that are AC3 5.1 surround will only show 2 Channel in the information when I press the Select button, but I can hear 5.1 surround sound, so I’m not sure if it’s just not showing the info correctly or what, but it sounds like surround to me (i.e. center channel will have dialogue while the rear speakers will have background sounds and the front speakers will have foreground sounds). Hope that helps.

So I’ve completely wiped everything, regcleaned all codecs off, made sure no directories were left anywhere.

I installed everything to the T from the guide, and now half of my videos don’t play at all, claim they’re missing a video codec. I installed FFD, Haali splitter and then Tversity, and they just don’t work. Not on Windows, not on PS3.

No sign of anything AC3, etc.

Any ideas?

EDIT: Just tried to run FFD config, and it crashes saying I need to reinstall. Anything like this happen to anyone else?

EDIT2: Turns out the FFD install was corrupt. I have all video files working on PC, but not all work on PS3. Some MKVs don’t work, most MP4s, and I still can’t seem to stream anything at all. Great guide, but sadly didn’t work all the way for me.

[quote="counsil"][quote="joksi"]No, i havent had success in streaming MKV with 5.1, always corrupted data. I have tried with ffdshow alone, and with ac3 filter. It just wont work. However, if i use the avisynth/mencoder option in PS3 Media Server with ffdshow handling the 5.1 sound it works, and it works with Mencoder alone handling the 5.1 too. So this tells me the issue is within TVersity not beeing able to work together with ffdshow or ac3filter, which PS3 media server is.

I have however suceeded in using CoreAVC instead of ffdshow for mkv (h264) with TVersity, which i have read somewhere wouldnt be possible cause its said that CoreAVC cant transcode. It also works with PS3 Media Server, that is CoreAVC.

It seems as already said that the issue is within TVersity, regarding the 5.1 sound.

In regards to your statements about MKV2VOB and tsMuxer, i cant say anything about MK2VOB, but tsMuxer however doesnt transcode anything, it only remuxes the video (=untouched) to another container, in this case M2TS, which PS3 reads natively. The video inside MKV container is almost always AVC h624, which the PS3 of course supports, but not in MKV container. I have remuxed 720p 4 GB videos with tsMuxer and it takes only 2-3 min, thats not so long? :)

Also PS3 Media Server has this extra option, remuxing the video on the fly using tsMuxer (its bundled with PS3 Media Server). This isnt a bad thing, if you dont need or want subtitles that is. Too bad PS3 dont accept subtitles with M2TS, if it did all problems would be solved and tsMuxer option with PS3 Media Server would be the easiest and most efficient way of streaming all HD video, certainly MKV files! This is, as already stated, because tsMuxer only remuxes, and not transcodes, the video. This results in the same quality as the source MKV, and no noticeable load on the CPU running the streaming server.[/quote]

You are correct, most MKV files don’t need to be transcoded, but some do. In those cases, MKV2VOB will transcode the MKV files for you, but it takes a long long long time. But in the end, you will have an M2TS file that tversity can stream with 5.1 audio. In my opinion, the transcoded M2TS file looks and sounds great, but I just don’t want to do this step. Tversity should be able to stream 5.1 when transcoding on the fly since PS3 media server can… plain and simple. I wish I knew more about all of this stuff so I could write an intelligent email to tversity stating how PS3 media server does it, and how they could do the same. I would think that they would be able to implement a fix rather easily if they were just given some direction.

To answer your question, no I don’t need subtitles. Therefore, I agree with you, using tsMuxer to remux my MKV files on the fly (with 5.1 sound!!!) using PS3 media player is my best option. But, for the stubborn MKV files that need to be transcoded, I use mencoder.

I have never used CoreAVC. Is it worth the money? How is it installed? What codecs (codec packs) do/can/should I eliminate if I do use it? Also, do you have any suggestions on how I should setup all the options in PS3 media server?[/quote]

Well, this is true, some files have for instance this higher “profile” which makes the video black with a simple remux. Too bad we cannot eat the cake and have it left :P
I would be satisfied with only subtitles supported with M2TS,cause i havent yet come over an MKV not being playable without transcode.

Im not sure if its worth the money, but its said that CoreAVC is the fasted h264 codec and requires a slower CPU to decode then ffdshow. If there is quality differences, I dont know. Its installed with a double click on an installation file, as easy as that :) Well, you could go with our without ffdshow together, the important this is to disabled ffdshow for h264 and let CoreAVC do this processing. Other formats will still be handled preferrably by ie ffdshow, and sound by ffdshow or ac3filter. So CoreAVC is mainly for h624.

Sorry, but i dont have any preferable setups in PS3 MEdia Server, cause I have yet to find the best setup overcoming the all so known stuttering. Im not sure completely what it depends on, sometimes it looks like the PS3 wireless lan card is too poor by design, and sometimes it looks like its PS3 Media Server that produces to high bitrates from the source file when transcoding. Many times a mkv with original 10Mbps bitrate hits 150Mbps bitrate with best settings in PS3 Media Server, which truly confuses me. That is also one reason wh i would prefer only tsmuxer option, cause it doesnt make any changes to the video nor the bitrate and therefore most 702p and even 1080p will be streamable over WLAN cause its about 5-15Mbps bitrates, while Mencoder or Aviosynt options go way higher in transcoding… But, i must use this when it comes to subtitles still,so its a bit restricting.
Even when I hook up the PS3 over ethernet 100mbit, or gigabit, it doesnt make any difference, over WLAN the stutter starts at somewhere over 25Mbps (naturally, most WLANS dont handle more than 20-25Mbps), but with wire it starts at much higher bitrates. IE, 150Mbps is not streamable bitrate over standard 100Mbps wire, but over gigabit it should be but it seem it isnt. The question then is is its because this bitrate is even too high for the PS3 itself, or if its my CPU not beeing able to keeup up with smooth transcoding at this very high bitrate. I guess both parts is partly the issue.

If it’s showing 2 channels in the information, it’s NOT 5.1

Just because you can hear the rear speakers with rear sounds and the front with Foreground means nothing - Prologic II simulates that, which is what happens when you have 2-channel sound.

If it doesn’t show 5.1, it’s not 5.1

As in

If it doesn’t walk like a duck, sound like a duck or look like a duck - it’s not a duck.

Getting this thing to work is driving me nuts. I did everything in this thread and tried other combinations using CCCP/Klite. I’m not sure if I’m not totally sure if I’m uninstalling all the codecs in my computer. I don’t know to check if my computer is actually clean.

WMV & WMA should be disabled in FFDShow Video & FFDShow Audio. VC-1 should also be disabled as this will be handled by WMV8 or WMV9

**your transcoding settings in Tversity (Tversity / Settings/ Transcoder/ Windows Media Encoder should have WMV8 or 9 selected ( I use WMV8, best results IMO). Make sure it isn’t disabled.

Please answer the following:

  1. Do you get audio in Windows with WMV?
  2. If so, then do you get audio in only some and not others? IN WINDOWS? only on PS3?* both? This would indicate a particular issue w/a type of WMV, such as VC-1 (common).
  3. Do you have other codec packs installed? If so, re-read all of the instructions, starting at the beginning :)

If you get either issue 1 or 2, the key is IN WINDOWS. If the same thing happens in Windows, I’d start from scratch because you either 1) Changed the default FFDShow settings (which you shouldn’t have done) to handle either WMV, WMA and/or VC-1, in either or both FFShow Audio or Video, which it shouldn’t or 2) Something didn’t install correctly.

let me know what happens.[/quote]
Still not working despite full reinstall, I’m getting no audio from VC-1 and some MPEG-1 files don’t play at all. All the files play fine in windows.

Have to agree with some of the recent comments; this is just way too much work. I’ve tried for weeks to get this to work on my clean WinXP media server. Heck it works on my “dirty” Vista machine and I didn’t follow any instructions! Can’t get anything to play right now. I also can’t tell by the new OP if we’re supposed to install a codec pak in addition to fddshow and Haali. Anyway, I’m off to try PS3 media server.

So, I just want to be clear, KarnaG3. You basically wrote this guide only as a means of getting everything to work right with TVersity and PS3 THROUGH Windows, but not necessarily INCLUDING Windows, right? Specifically, you tell everyone not to use AC3Filter. What about those of us with a nice sound system at their computer that has spdif input and want to get AC3 sound on the computer as well? Are you saying you have to sacrifice AC3 at the computer to get it at the PS3 with TVersity?

Question time! To start off, while originally installing, I didn’t follow your directions at all, mainly because i didn’t know they existed. So I’m now at the point where most things work. Most of my AVI files work, except on certain ones the audio is wonky. well, makes sense. I probably have AC3 installed somewhere. I just have some random files and all MVKs that won’t work. So I figure I’d try this, but first I have a few questions:

  1. I’m guessing CCCP is a no go because it contains codecs other than FDD Show and Halli splitter, right? I’ve always used CCCP and would prefer to stick with what I know if I could.
  2. after uninstalling all my codecs(including those in my Nero Express 6 install) and what not and going through your setup, am I able to reinstall Nero and CCCP? Or will that break it again?

Thanks in advance for any help.

EDIT: New Development: Seems I was able to unwittingly playing an MKV file at one point while testing it earlier today. It’s the only MKV that will play, most likely because it only had one audio and video track. Just thought I’d throw that info in here in case it would be helpful.

[quote="Vitalogy"]Hi people,

KarnaG3 i have some questions for you:

So i’m gessing that Vista Codec Pack, that was mentioned in previous post, is no longer needed. But, you don’t say anything about the codec pack that came along with tversity, i mean: will we install it or not?

I do know what codecs i have to install (ffdshow and hali, in this right order) but what about the codec pack that cames with tversity? Please clarify this.

On previous post, before edited, after install ffdshow we had to tweak a bunch of things related with the video extensions to open with, now we just leave it alone?

Another thing, i have the previous tversity running yet and my resolution is 1920x1080 and it works pretty well, but i got to say i have a Q9350 2.5Gb, should i keep this in the new version or is better to resize?

Also, no editing the config or profile files anymore?

Thank you for your time.

Regards,
Vita[/quote]

Please, can someone give me a hand here!?

To Kensin and Vitalogy.

Although he doesn’t mention it, he used to, and I would still recommend the Vista Codec Pack from shark007.net (even on a WinXP machine it will work perfectly as I’ve tested both). There is also a supplemental x64 Components Pack you can install if running Vista x64 (only AFTER you install the Vista Codec Pack, which is 32-bit only). This is an extremely painstakingly complete codec pack that will provide perfect playback on third party players as well as natively through windows media player and windows media center. I’ve only encountered a problem once with a certain poorly encoded flash video file that would not play (it would play in whatever implementation is used in VLC, but not in MPC or WMP). Even if you only use a third party player like media player classic (I recommend media player classic home cinema), when windows media player can play it, you will be able to get pretty video thumbnails in your video folders on your computer :o .

That said, the package is primarly focused on FFDShow, which is in itself a codec package. Halii is in there as well. You should be able to install this codec package and have things work right out of the box as it has FFDShow preconfigured correctly. The only extra setup you would need is if you have an AC-3 and/or DTS decoding speaker receiver hooked up to your computer. In that case, you would want to disable AC-3 and/or DTS decoding in the FFDShow settings and likely need to install SPDifer (this is not AC3Filter, it only handles ensuring that your AC-3/DTS/etc signals are not processed and sent directly over your S/PDIF to your receiver when detected).

As for the codec pack that comes with TVersity, don’t install that. You could, if it were the only codec pack you were going to install, but it’s not the best solution, and definitely don’t do it if you already have something like the Vista Codec Pack installed.

As for the config files for TVersity, I would still recommend running a ctrl+f search for "mpeg16" in the profiles.xml and changing both of those to "mpeg2" for optimal quality to bitrate ratio on such files.

I had the issues explained further in this post before. I did some fiddling with Tversity and ffdshow and I got everything streaming perfectly. This lasted two days. All of a sudden the issues came back so I followed this guide. When they came back absolutely nothing on my PC or PS3 was changed. No router changes, no software, no hardware. The issues just came back.

Followed the guide to the letter. Uninstalled, reboot, clean, reboot, FFDSHOW, reboot, HAALI, reboot, Tversity, reboot and still doesn’t work.

Nothing I try to play works. Everything stutters. The pauses occurs every 2 seconds or so. Even just mp3 files stutter horribly. I noticed that when streaming videos the kbps for the sound would drop to nothing when stuttering. The video Mbps would remain normal (5-7 depending what is watched).

Running Vista x64. Computer is wired to the router. PS3 is on a wireless connection with 85% signal.

All files and formats play properly on my PC.

Hey MeatPie,

My issues have recently gone away with stuttering. This was after I moved from XP x64 to Vista Ult x64. So, it’s a fresh install. My issue now is that the (as I understand it to be) flash-based GUI doesn’t respond in a lot of areas so I am forced to add media with the mshare command prompt executable. That’s neither here nor there, though. I’ll make sure this thing is still working for me when I get home today and report back with any suggestions I can come up with as we have nearly identical setups.

EDIT: Took longer to get back to you than I intended. Anyway, it is indeed working fine for me at this point, and I honestly am at a loss as to why. Now I’m starting to think there are minute things, perhaps registry related, that are cause the network issues for people. Unfortunately, I wasn’t able to pinpoint anything. So, I have no real advice short of a completely fresh windows/tversity installation. Let’s hope that’s overkill.

This Tversity / PS3 stuttering is driving me nuts

I’m running WHS on a E7200 with 2GB RAM and a wired gigabit LAN. PS3 is the original 60GB model.

The more I look at it the more it seems to be a PS3 network stability issue. I have scanned all the forums and made all the adjustments. It worked perfectly the first time and then began to ‘stutter’ on PS3 2.5. But when I downloaded Tversity 1.0008 and PS3 2.53 it started working again, but only for 24 hours. It’s now stuttering after 2.5Mb/sec with no adjustments !!! Note, when working properly I can stream HD .mt2s files at 60Mb/sec (please when quoting bandwidth use ‘B’ for bytes, ‘b’ for bits - the PS3 displays Mb, not MB). And yes I agree, 1000Mb half duplex on the PS3 seems to have more success than full duplex.

I am also using Jumbo frames (9K MTU) but have disabled Largesum and Checksum offload on the server NIC.

I also have an XBox 360 and a Mediagate MG-350HD both with varying success on the .mt2s streaming. The Mediagate rarely stutters which is why I think it’s a PS3 issue.

It is a windows vista setting I am 100% sure of it. MediaTomb under 64 bit linux works flawlessly on the PS3. All files work. MKV, DiVX etc. These are the same files I try sharing through Tversity. I remember also fiddling with the services in Vista when I got it to work. So I think my issue is that one of the services that is running, shouldn’t. Or one that is not running should be running. Anyone have a list? OS is Vista x64 ultimate.

Hi all!
I’m new to the forum and have a question. Tversity is downloaded and I can open photos and view them on my ps3, but the thumbnails don’t show. Yes it is a minor issue, but it is annoying. Any suggestions?

Thanks!! :)

Hi,

Thanks a lot for this guide! Very useful. I took the time to read through all of the posts but am still having issues with mkv files. I am getting the "data is corrupted" error message from the ps3.

I followed the instructions precisely three times but still cannot get the files (mkv) to play. Here are the relevant details:

ffdshow ( 2527 2008-12-19 )
mediasplitter ( 1.8.122.18 )
tversity (RC5)

Prior to install I had uninstalled all codecs (regclean) reboot, installed codecs ffdshow --> mediasplitter, reboot, regclean, reboot, tversity (no tversity codec pack).

I can view the media via mpc.

The guide said to use the latest of ffdshow, but I noticed in several comments that you were using an older version than I have (2527)…I’m going to downgrade but wanted to see if you had any suggestions.

Thanks again for keeping this up!

Aaron

hello my friends. I have tried this guided, but it doesn’t work for me. I mean it plays avi files with a subtitlebut i can’t get to make the mkv work. In the tversty status bar it shows the following error code :
Started streaming “movie.1080p.BluRay.DTS.x264-hV” to “Sony PS3”

Error - Could not start decoding using direct show, aborting…
Error - Could not start transcoding
edit:
i manage to play the mkv but no subtitle
the avi are still working with a subtitle

please help me. thanks in advance

Funny that because Vista 64 doesn’t work for me.

Hi there,
I followed your excellent guide to the letter and for my surprise it all worked first time.
From my previous experience with media servers it takes a week to really get everything working.
However after about a week and no change in the settings all my hd files appear as corrupt data when I try to access them.
I tried rebuilding the library.
De installing all codecs and tversity and installing them again - about 3 times and still I get the same message.
Other files are working ok - only the hd x264, mkv etc.
How do i fix my problem?
Many thanks
Nik