Tversity - Making it Work for PS3 *updated 11/23/09

having the audio issues too.

Done all like the thread says, cleaned reg, uninstalled everything etc.

The video plays so well, but audio… it plays too slow even though I have disabled the ones you told in ffdshow audio.

also, I can play a few mkvs , not all. check the below images please.

The mkvs that I can play -
the mkvs that I can NOT play -

Like the videos on the 2nd link, it crashes my tversity. I would have to reshare tversity.

Thanks in advance.

no one has an idea to solve the issue ?

I installed the Vista Codec Pack that has been suggested in this thread and I was also experiencing the garbled sound issue with videos that included AC3 audio. After tracking which decoder was actually decoding the audio I found out the issue was AC3filter’s SPDIF passthrough.

I ran the "SPDIF configuration" and disabled the passthrough for AC3, DTS and MPEG Audio and that fixed the issue.

I have 2 mediashares :

Windows Media Players : this one doesn’t transcode, just streaming. And it plays the audio well, and the most important part that my receiver connected to PS3 can play those files Digitally, dolby. ( z-5500 logitech) I can see it on the controller screen.

Tversity : this transcodes, and when he transcodes ( If I select it on the configuration ) my receiver can not see the digital sound, and it plays stereo, and then the sound is garbled. When I turn the transcode off , everything is fine with sound, my receiver catches the digital sound. ( I am using optical cable between ps3 and receiver btw )

What can cause this problem ? I guess, if I can make it catch the digital sound, it will work.

ps. spdif didn’t work for me.
ps . I am using K-Lite codec pack, and all others are same like thread tells.

OK, just solved the audio issues ! it seems I should have opened tversity via my account, not local system account :D -I thought I’ve done this, but anyways lol-

a new problem : 5.1 … I can not have 5.1 sound while tversity transcodes mkvs. If I turn transcoding off, it plays well, but all we need is transcoding to get all mkv s play.

My ac3 filter’s output format is : PCM16 3/2.1 (5.1) 48000 … 5.1 channel. rate is AS IS.

I’ve researched the forum and found this guy : viewtopic.php?t=5292

What should I do now ?

thanks in advance

[INVALID POST]

That is exactly what I have got working, the MKV files claim to be h264 in their filename, however looking at them with video inspector it tells me that they are mpg4 and ac3, however (as I am finding out more and more) I’m new to all this encoding stuff and so maybe either videoinspector is wrong, or it’s right and the filename is wrong, or they are right and h264 can be contained within the mpg4 sigh Can anyone correct my thinking on this? :)

As far as getting it working with my ps3 it took a few days of messing around and I suspect that had I discovered the problem with the 2nd user in the first instance it would have all been working ok after just following KarnaG3’s guide to the letter.

As it happens I ended up reinstalling the o/s setting all that up without any codecs, installing the latest versions of ac3filter, haali splitter, xvid, divx and ffdshow, and then configuring ffdshow to not decode ac3, dts, mp audio. I made sure that WMP could play the files using the correct codecs (mainly by enabling the tray icons in all the codecs and seeing that haali, ac3filter and ffdshow video decoder all appeared when it was playing in WMP) Then followed KarnaG3’s steps for installing TVersity, the latest version as follows:

  1. Install, run the config wizard, dont install the tversity codec pack
  2. Ensure that you do not start the service or run the UI (uncheck the last 2 boxes in the setup wizard)
  3. Open the services and select tversity and change it’s logon to the correct user and password
  4. Find the profiles.xml file in the tversity folder and change the mpeg16 to mpeg2 in the playstation3 profile (this seems to be important, my ps3 wouldn’t play the files until I had done this)
  5. Then followed KarnaG3’s instructions for configuring tversity

Oh and I did follow his instructions to the letter, including all reboots in all places

And after that my PS3 is playing the mkv files like a charm with correct ac3 audio!

What exactly is the problem when you try to play them? And what does tversity say when it attempts to transcode them (I am using the latest rc of 1.0.0.3) there is a status tab that shows transcoding status and what devices are connected?

Matt

Your computer is likely too weak to transcode efficiently. How big is the picture? 720p, 480p? My processor can transcode 480p without a problem, but 720p can have a few studders here and there it and it is much faster than your processor (C2D 3.25Ghz 2GB Ram)

INVALID POST

Four hours straight today and I’m ready to pull out my hair… MKV files play now but without subtitles. I think my problem is directvobsub taking over, like you… when I play an mkv on my PC the directvobsub icon pops into the bottom right tray, no ffdshow icon.

However, I can’t use gabest as you suggest. If I switch to gabest, TVersity crashes anytime I load an mkv. I have to restart the service. Using Haali the file plays great but without subs, using Gabest the TVersity crashes.

This is sooooooooo frustrating… TVersity 1.0.0.2 should still be a <1 release, it doesn’t feel like a finished product when it needs 5 hours of troubleshooting and still doesn’t work…

I want to thank u personally! Absolutely brilliant! Followed ur instructions step by step- even the rebooting which was annoying! Bt it workd! Ive tried 4 different versions of nero, wmp, twonky, gore, n many others for the last month and NONE cld transcode RMVB on the fly! But i will say this everything seemed lke it was not working till i did these 2 extra steps-
Stop server. Go to Star/Run and type ‘mediaserver.exe -debug’ let it debug
Then go on your playstation- to network connections and select easy and just reset ur connections- im using LAN line!
FINALLY i cn watch season 1-4 of boston legal using my ps3 on the tv thank u!

INVALID POST

INVALID POST

INVALID POST

Well after a few days of messing around and hair pulling I have finally got MKV files streaming to my PS3 with the AC3 audio working correctly.

I originally followed the OP’s guide, uninstalled my xvid, divx, and ac3filter codecs and installed vista codec pack, which then allowed me to view my mkv files in WMP, then installed tversity as instructed and created a new user to run the service under, set all the settings as instructed and did all the reboots where instructed.

This got my PS3 able to play the mkv files, however the audio was corrupted, and no amount of setting the right codec in ffdshow or ac3filter would make any difference to this. This was so much better then the corrupt data message I had before though :)

So, reinstall my o/s from scratch to see if it was any of the old codecs settings hanging around. Still the same problem.

Started to investigate more about how to get information about what codecs TVersity was using, because if I enable the tray icons for the codecs and run the file in WMP i can see it correctly loads FFDShow video, AC3Filter and Haali.

Then I discovered starting the media server in -debug mode, which solved all the problems, and this showed me that TVersity was using the correct codecs (the tray icons appear), however starting it up as a service again and it went back to corrupt audio. Now I agree with a number of posts on here about this audio problem it’s some sort of codec confusion issue.

However, running ‘mediaserver -debug’ is not a viable solution as it has to be done every time you want to use it, and I don’t know what other stuff enabling it for debug does (e.g. slowing it down with additional checking etc)

So, what is different between -debug and the service, one big thing is that the service is running under the new user I had set up, and under debug it runs under my user. Changing the service to run under my user solved all the audio problems and it works perfectly.

It seems that the new user I set up just before modifying the service (as instructed to in the OP guide steps) gets screwed up codec settings. I even logged on as that user and set the codec configs again (they all looked right in the config apps, but just made sure) and it made no difference.

I think what you need to do is to create the new user right at the start of the steps, before all the codecs are installed, in my many test re-installs of my pc over the last few days I did have one of them working with correct audio using a new user rather than my current user, and iirc, i had created the new user early on in the installation, way before the codecs were installed.

So for people that have followed these steps and created a new user account to run the service under and are still getting garbled ac3 audio, try running mediaserver with -debug, if that works then change the user the service is running under to your own user and see if that works.

And if you are following the guide from scratch and intend to use a different user for tversity service, make sure you create the user before installing the codecs!

Hopefully I can save some other people days of messing around that I have just been through :)

Matt

Thanx man but wat exactly is the advantage of installing another user- i remember reading in the original post about the ‘many advantages’-
‘***note: alternatively (I suggest this if you can manage it) you can create a 2nd user account, and use this name as the logon for the Media Server. This has many advantages, but don’t worry about it if you can’t figure it out.’
so wat exactly MORE can u do wif another user?

HELP-
Ive been trying to transcode flv, some files work others done. The ones that don’t, I got this error in the status section-
‘error - Skipping decoded video buffer since its size too small, buffer 277, frame 307200’
any1 ideas??

:? :? :? :?

Yeah, you can set up that user as a cut down user to improve throughput of transcoding according to the OP in this post:

http://forums.tversity.com/viewtopic.php?p=48636#p48636

But as I found out, it does mean you need to get the codecs right for that second user, I gave up in the end :)

Matt

[quote=“dominatingtnt”]Thanx man but wat exactly is the advantage of installing another user- i remember reading in the original post about the ‘many advantages’-
‘***note: alternatively (I suggest this if you can manage it) you can create a 2nd user account, and use this name as the logon for the Media Server. This has many advantages, but don’t worry about it if you can’t figure it out.’
so wat exactly MORE can u do wif another user?[/quote]

Guys, I’ve been trying to get MKV to work with TVERSITY on PS3 but everything I tried failed.
The MKV files in question have h.264 video, ac3 or dts audio and sometimes SRT subtitles.
I’ve been reading through this thread and I’ve been trying it out several things and I could never get any mkv with h.264+ac3/dts to actually stream to the ps3.
I could only get h.264 and ac3 to work if into a m2ts container renamed to .vob. Subtitles in that container do not work over the network.

As far as transcoding goes,

For mkv type 1 (h.264+ac3), tversity should be able to stream without transcoding.
For mkv type 2 (h.264+dts), tversity should only stream the video and transcode the audio only from dts to ac3.

Is there any way to get it working as I explained it above?

You really need to give up on the mkv. I was running mkv’s okay for a while, full resolution through transcoder, but the picture would stutter a second or two every 4-5 min as the computer tried to keep up. The only way I could get the mkv’s to work was to limit the audio to 2.0, it just wouldn’t play if I tried 5.1… I used MKV2VOB to convert all of my mkv’s to mp4’s. Now no stutter, and 5.1 audio for all of my files, and computer doesn’t have to transcode.