Tversity - Making it Work for PS3 *updated 11/23/09

I’ve followed everything verbatim, and it’s worked out well. However, recently I haven’t been able to play xvid files smoothly, when before I was able to. The xvid videos will freeze for a few seconds and then play, or just freeze and not move at all after that. What could be the possible source of this problem?
edit
I’m getting a sense of what the problem is, when I hit select while the video is playing, the readout goes like this
“MPEG 2CH 48khZ ** kbps” and next to that “MPEG 2 ** mbps”
the value for kbps drops to double digits when it starts lagging. I’m on wireless.
EDIT - Solution
Found out that it was because my wireless was dying out on me. I had to switch routers, but it’s working now.

Works for me, tho my requirements may be less than others - but pretty much every torrent has played so far. My only problem is that whenever I shut down the PS3, or if I run and then quit Folding Home, I lose the connection to tversity, and the ps3 cannot find it again. I then have to stop and restart tversity, and it immediately shows with no search. Couldn’t locate any info in this thread, any suggestions?

Great guide, Very detailed and specific. One thing though, What’s the password for the registry mechanic?

Thanks

Ok I got Tversity to work for the most part but one thing, It wont play .MP4’s. On my ps3 it said that the content could not be accessed, The folder or file may have been deleted. On the Tversity it said that Transcoding could not be started. Any ideas on what to do?

EDIT: Ok I figured out what was the problem with the DNS errors I was getting, It was my virus protection program. I was running BitDefeneder 2009 and even though I had added Tversity to the white list and opened the ports for it I was still getting the errors so I switched to Kapersky 2009 and everything is running smoothly including my .mkv files. Thanks for the great guide. :wink:

  1. thanks!

  2. mp4s can be fickle little bastards, mostly because, like mkv, there are different versions. The first thing I would check is that the folder containing the mp4s is set in tversity, under advanced settings for that folder to transcode always… If you have other files in the same folder that you DONt want to transcode, you can move them to another folder or add the mp4s file by file, etc. Make sure you have a codec assigned to handle mp4, I like the gabest splitter, but the vista and klite packs have more than one that works, such as haali or others in ffdshow. Make sure to restart after changing these settings. You may want to stop sharing, make the transcoding/folder change, restart sharing, then try …shouldn’t require a restart. If it doesn’t work, check the codecs …restart.

  3. while the above steps should ensure you’re transcoding correctly, the error message you’re getting is a folder access issue… I usually get this error when I forget to turn on my seagate external drive that houses my media. So I would ask: a) what drive is the file on and b) how is it connected? ie network, USB/firewire,etc. Is it in your local drive and or on a seperate partition?
    If the folder you’re accessing is on an external drive (ANY drive other than your windows drive) you probably need to “share” that drive AND that folder (you can try just sharing the folder but sometimes this still fails).

If it is in a separate partition but still in the windows drive, you should
be ok just to share the folder.

You want to follow the steps to create a login that is used by the tversity service to ensure that the service itself has folder access. You shouldn’t need to do anything to give access to the new login to everything you have access to, but be aware that you can define the type of access each login has and within the specific folder whether that login has read access or read/write, etc. It should have full access.
Lastly, I’d suggest removing the folder. From tversity and readding it. Moving files and folders, renaming them, etc diesnt pass to tversity, so if you have a brain fart like me and rename your media folder and don’t scan the new folder in tversity it will still show the files and folders as exactly what you had before.

Try checking some of these things and let me know what happens!

[quote=“SINIStER”]Great guide, Very detailed and specific. One thing though, What’s the password for the registry mechanic?

Thanks

Ok I got Tversity to work for the most part but one thing, It wont play .MP4’s. On my ps3 it said that the content could not be accessed, The folder or file may have been deleted. On the Tversity it said that Transcoding could not be started. Any ideas on what to do?

EDIT: Ok I figured out what was the problem with the DNS errors I was getting, It was my virus protection program. I was running BitDefeneder 2009 and even though I had added Tversity to the white list and opened the ports for it I was still getting the errors so I switched to Kapersky 2009 and everything is running smoothly including my .mkv files. Thanks for the great guide. :wink:[/quote]

Can anyone advise weather tversity would be better on the ps3 or 360? im trying to make a purchase decision.

Ok I tried it your way but now my PS3 cant find a media server and before it could. Whats going on!?

Just joined up to say thanks to KarnaG3 for putting this together :D

I only downloaded TVersity the other day then came straight here, followed the guide and everything works perfectly!

Hi,

Having an issue with Tversity and garbled sound after upgrading to latest version, new codecs detailed here etc.

Followed the instructions to a tee, un-installed all codecs, cleaned registry, installed in order mentioned, rebooted between steps etc.

Now some files that used to play fine (Using old ‘vista’ codecs and transcoding always) no longer work properly, I mean literally before - reason I upgraded was because one particular movie couldn’t play subtitles so I thought I’d give upgrading a go.

They do work ok in media classic, so I’m even more confused as to the issue causing me problems.

Also if I set the to transcode always my PS3 waits for ever then tells me it’s a corrupted file after taking forever to get there. I got a dual core machine with 4GB and decent graphics card and my network is auto-ing at 100/full (BTW the posts before - it’s impossible to auto-detect full duplex, so either both ends of a connections need to be auto-auto or full-full, otherwise you’ll get a duplex mis-match and the subsequent performance issues you’re all seeing).

Any suggestions? (Don’t say follow instructions, I have - three times using two different registry cleaners to be sure).

[quote="joksi"]No, i havent had success in streaming MKV with 5.1, always corrupted data. I have tried with ffdshow alone, and with ac3 filter. It just wont work. However, if i use the avisynth/mencoder option in PS3 Media Server with ffdshow handling the 5.1 sound it works, and it works with Mencoder alone handling the 5.1 too. So this tells me the issue is within TVersity not beeing able to work together with ffdshow or ac3filter, which PS3 media server is.

I have however suceeded in using CoreAVC instead of ffdshow for mkv (h264) with TVersity, which i have read somewhere wouldnt be possible cause its said that CoreAVC cant transcode. It also works with PS3 Media Server, that is CoreAVC.

It seems as already said that the issue is within TVersity, regarding the 5.1 sound.

In regards to your statements about MKV2VOB and tsMuxer, i cant say anything about MK2VOB, but tsMuxer however doesnt transcode anything, it only remuxes the video (=untouched) to another container, in this case M2TS, which PS3 reads natively. The video inside MKV container is almost always AVC h624, which the PS3 of course supports, but not in MKV container. I have remuxed 720p 4 GB videos with tsMuxer and it takes only 2-3 min, thats not so long? :)

Also PS3 Media Server has this extra option, remuxing the video on the fly using tsMuxer (its bundled with PS3 Media Server). This isnt a bad thing, if you dont need or want subtitles that is. Too bad PS3 dont accept subtitles with M2TS, if it did all problems would be solved and tsMuxer option with PS3 Media Server would be the easiest and most efficient way of streaming all HD video, certainly MKV files! This is, as already stated, because tsMuxer only remuxes, and not transcodes, the video. This results in the same quality as the source MKV, and no noticeable load on the CPU running the streaming server.[/quote]

You are correct, most MKV files don’t need to be transcoded, but some do. In those cases, MKV2VOB will transcode the MKV files for you, but it takes a long long long time. But in the end, you will have an M2TS file that tversity can stream with 5.1 audio. In my opinion, the transcoded M2TS file looks and sounds great, but I just don’t want to do this step. Tversity should be able to stream 5.1 when transcoding on the fly since PS3 media server can… plain and simple. I wish I knew more about all of this stuff so I could write an intelligent email to tversity stating how PS3 media server does it, and how they could do the same. I would think that they would be able to implement a fix rather easily if they were just given some direction.

To answer your question, no I don’t need subtitles. Therefore, I agree with you, using tsMuxer to remux my MKV files on the fly (with 5.1 sound!!!) using PS3 media player is my best option. But, for the stubborn MKV files that need to be transcoded, I use mencoder.

I have never used CoreAVC. Is it worth the money? How is it installed? What codecs (codec packs) do/can/should I eliminate if I do use it? Also, do you have any suggestions on how I should setup all the options in PS3 media server?

Hi.
This is my first post here.
Two questions:

  1. How can I force TVersity to play 24Hz to my PS3 because I mainly play m2ts HD content and when I check with my TV, it says 60Hz (these are played without transcoding).
  2. Is it possible to transcode HD 1080p and AC3 m2ts files that have VC1 video streams inside via TVersity to PS3?

Thanks

Hi guys

I think I am acting dumb here, so please excuse me…

My setup is as follows:

PC -> 200mbps Home Plug
PS3 (2.5 - UK 40GB) -> 200mbps Home Plug
ADSL2+ Router (SpeedTouch 585n) -> 200mbps Home Plug
Sony Bravia KDL-46V2500 (720p, 1080i)

I am trying to stream HD content from the PC to the PS3 using Tversity (tried using Twonky Media but it doesnt pick up .mp4).

In order for the Media Server to see the HD file, I have to mkv2vob the file and output it as a .mp4.

If Tversity is set to use transcoding, the image is dark, blocky and the sound is like it is playing underwater.
If I disable transcoding, it plays fine.

If the content is 720p it plays it fine on the PS3.
If the content is 1080p, I thought it would downscale it to 1080i but I get no video and only sound.

Is there anyway to transcode the 1080p to 1080i and have excellent quality or will I need to only view 720p content?
Is there a better way to stream the content?

My PC is an Intel Duo Core 6600 2.4Ghz, 2GB ram, 2 x 500GB SATA HDs.

I’ve also installed the latest TVersity and codecs, and set the output transcode res to what my TV supports, but when I now play content, the mediaplayer.exe crashes.

just went through KarnaG3’s guide.

My PS3 is set to output at 720p and 1080i (and is it 576p?).

Last night when I tried editing profiles.xml, it would crash the mediaplayer when I try to stream a .mkv.

Tried viewing a 720p movie using transcoding and it was all blocking and the sound was warbled. It’s driving me nuts!

If I try streaming 1080p content on my 1080i TV, it just gives me a black screen and audio.

arrghhhh

Hi.

Ive been using TVersity for a couple of months with my PS3 wireless. I just installed it and it worked perfectly. Since PS3 patch 2.50 ive experienced some random lag/freezing when streaming movies to the PS3 so i decided to give everything a clean install and i followed the this guide.

I couldnt follow the service.msc instructions. And i cant see the point of it either since everything worked smoothly before and i did have to do anything in services. but other then that ive folloed every instuction with every reboot and critical.

Thing is the lag dissapered, but instead subtitles stopped working and the quality of the movies got worse…

Im totalyl lost in all the mkv, vod, mp2, mp4 stuff talked about when discussing topics like this. What i can say is that all my movies show up as mpeg1 on the screen on my PS3 - cant recall if they did that earlier.

i watched a .divx movie like an hour ago with subtitles and the picture was good on my tv but the film lagged, now when i watch it i cant get the subtitlwes (when pushing triangle-subtitles it says there are none - ive embeedded them in to the file with aviaddxsubs) and the picture is all smeary-like (is that a word - english is not my native tounge :)) BUT theres no lagging going on.

(oh i deselected the always transcode option in tversity and selected only when needed since i mostly watch divx:es - this may not be logic at all since im a codec-retard)

Dont know if i have given you enough to work with… hope someone can help.

Edit: Think i sorted it. Switched to Gabest splitter sorted my subissue and upping the resolution in transcoding seems to handle my other problem. That all i did atleeat and now i got good picture (considering the format of the movie) and subtitles.

Hey KarnaG3,

I used your guide and it worked perfectly.

Thanks!

[quote="joksi"][quote="dark79"][quote="joksi"]What exactly did you to for 5.1?
I tried installing AC3filter, just because it looked like FFdshow mixer setup wasnt enough. But AC3 filter didnt improve anything.

I still get the same message as with FFdshow alone, "data corrupted", when i set it up to 5.1 channels. Switching back to 2.0 stereo solves the problems, however without any 5.1 channels.[/quote]

As it has been said many, many, many, many, MANY (ok, you get the picture) times before:

DO NOT INSTALL AC3FILTER!

I have already said that with AC3Filter installed, 5.1 WILL NOT WORK. It doesn’t matter if it’s disabled it still WILL NOT WORK.

If you have installed AC3Filter, you must uninstall TVersity, all codecs, AC3Filter, clean your registry settings AND START OVER.

Seriously, it’s not that hard. Just follow the instructions in the first post and it will work. Here’s the key part:

DO NOT DO ANYTHING DIFFERENT FROM THE INSTRUCTIONS!!!

You might be tempted to change the speaker settings when installing FFDshow from the default 2 channel stereo to 5.1 but DON’T DO IT!!! Don’t even mess with ANYTHING unless it’s in the instructions. Don’t even bother with the mixer in FFDShow. My Mixer settings are still at default which is 2/0/0 but all my AC3 5.1 divx files play with 5.1 surround.

If you don’t follow directions I can’t help you because that’s what I did and it worked just fine.

EDIT: I noticed you’re having problems with MKV and 5.1 Surround. My DivX files that have AC3 5.1 surround will play in 5.1 surround and it will show in the information when I press the Select button. My MKV files that are AC3 5.1 surround will only show 2 Channel in the information when I press the Select button, but I can hear 5.1 surround sound, so I’m not sure if it’s just not showing the info correctly or what, but it sounds like surround to me (i.e. center channel will have dialogue while the rear speakers will have background sounds and the front speakers will have foreground sounds). Hope that helps.[/quote]

Yes, i have only MKVs with 5.1 so I cant say anything about DivX.
Well, it clearly states 2 chnnel in PS3 and im pretty sure its 2 channels too from the speakers.
And if you re-read my post, you will see it clearly that im saying I turned to AC3 filter as a new solution, before that I had only FFdshow and that didnt work standalone either.

I have also tried streaming an .avi with AC3, test file sending out different sounds to all speakers one at a time. PS3 states 2 channels, and thats true cause no test sounds are coming from anything then the front speakers.

Well, for now I have no solution yet which is too bad, and it seems no one else either has one.
I think im going to switch over to PS3 Java MEdia Server completely, its much easier to setup, runs seamless and all 5.1 sound works great.
It can even play video material directly from RAR files, which is impressive, and soon it will feature .ISO streaming which is totally complete solution! It also has features like not transcoding, only muxing on the fly with tsMuxer, and DTS convertions to LPCM 5.1. Most MKVs dont need any transcoding, just demuxing, lowering the CPU load significantly and retaining original quality when streaming MKVs.

This other software also uses FFDshow for audio, so in fact it seems that TVersity is the failure link between FFDshow and the PS3 in regards to 5.1.[/quote]

joksi, did you ever get 5.1 to work when transcoding MKV files on the fly using tversity? I have searched and searched, and to my knowledge, no one has ever gotten anything but stereo (2.0) to work using tversity when it is transcodes MKV files on the fly. This really sucks. I am currently using PS3 media server (found at ps3mediaserver dot blogspot dot com) for all the same reasons you are. I can’t believe that PS3 media server has no problem outputting/streaming 5.1 surround sound when transcoding MKV files on the fly and tversity can’t.

If someone knows how to get 5.1 surround sound from mkv files while transcoding on the fly, please feel free to chime in. I already know how to use tsMuxer or MKV2VOB to re-package the MKV files to M2TS. This is what I am doing right now to get past the 5.1 bug.

Just so everyone knows, using tsMuxer or MKV2VOB to re-package MKV files to M2TS does have a few downsides. First of all, you have to do it (enough said). Secondly, if the MKV file isn’t perfect, tsMuxer and MKV2VOB can fail, even if you tell them to transcode the file. Thirdly, having to transcode the MKV files into M2TS takes a long long long time. Back to my third point… just because tsMuxer and MKV2VOB fails to re-package the MKV file to M2TS, this doesn’t mean that tversity will have a problem transcoding it on the fly. This is because tversity just skips past the bad data and moves on with the video.

Other than this one (but very big) bug, tversity is awesome. Unfortuneately, I agree with joksi, PS3 media server is better because it’s audio and video capabilities are far superior. Not to mention that is a lot easier to install. Really there is no install. You just unzip, double-click the exe file, and use. There is no need to install codecs, etc. unless you don’t want to use what comes with PS3 media server. I should also add that PS3 media server easily handles 1080P. If you read the FAQs, the video and audio inadequacies are what motivated the developer to write the PS3 media server program.

[quote=“TVren”]one curious thing though. I don’t know if this could be the potential problem. I notice when playing these AC3 .avi files under BSplayer, “Avi Splitter” shows up as a greyed-out filter even though the AC3 decoder is used.

I have made sure that avi splitter has been uninstalled correctly and it’s absent from c:\windows\system32 but somehow reference to avi splitter is still there. It’s not really a sound codec so I am not even sure how much of it affects the garbling sound.

The garbling/distrorted sound saga continues…[/quote]

AVI Splitter is a video splitter. It has nothing to do with AC3 (audio decoder).

Please do not uninstall anything included w/the FFDShow codec, or I won’t really be able to help. (please see notes after this indicating updates to the guide)

If you’ve uninstalled AVI Splitter, I recommend you reinstall from scratch. You can “disable” AVI Splitter when installing FFDShow for the first time, but it should be disabled by default. This doesn’t mean its not installed, just that the splitter program doesn’t run everytime you access an avi. That means it still available for FFDShow decoding if necessary, and therefore this is the reason I recommend starting from scratch.

[quote=“TVren”][quote=“KarnaG3”]
b) Assuming you are using the Vista or XP codec pack w/AC3Filter, if you still have “garbled” sound (NOT no sound…wait for it…wait for it… ) you have a codec conflict. Period. I still think you most likely have a PCM or other file type handled by AC3Filter that is also selected to be handled by ffdshow audio. Below is a screenshot of my FFDSHOW SETTINGS NOTE THE THINGS THAT ARE DISABLED* NOTE THAT MP3 IS ENABLED: even tho PS3 can decode it, it CAN’T decode it from the transcoded stream properly:

http://img520.imageshack.us/my.php?imag ... ap1db4.jpg http://img508.imageshack.us/my.php?imag ... ap2cc9.jpg http://img112.imageshack.us/my.php?image=ac3picaz8.jpg

Let me know what happens a) AFTER you change your settings to reflect mine b) make sure that AC3 settings reflect mine and c) you guessed it, reboot.

PS: If you have NO audio in WMP, you have NO codec set to handle the audio stream from the MKV. NOTE: Different MKV’s use different audio types. If one plays and has audio and the other doesn’t, right click on the file in WMP and select Properties to find out the codec used to decode the audio.[/quote]

Under Vista, I am having the same problems too of "garbled" sound on PS3 running .avi files that have been encoded with AC3 (checked using Gspot).

I have done the following but still no luck:

  1. Matched ALL the settings in ffdshow and AC3
  2. When I run the .avi files on the Tversity computer, I can see the AC3 decoder properly working, and ffdshow audio icon not coming up.

But still, after many reboots, uninstalls and clean installs, I still get garbled weird sound on PS3… sigh… :roll:

edit: i also uninstalled Nero too.[/quote]

PLEASE SEE FUTURE NOTES (AFTER THIS ONE :)) IF YOU ARE HAVING THIS PROBLEM.***

PLEASE NOTE: This does not apply to Xbox 360. This is PS3-specific, though should work for Xbox as well.

I installed the Vista Codec Pack that has been suggested in this thread and I was also experiencing the garbled sound issue with videos that included AC3 audio. After tracking which decoder was actually decoding the audio I found out the issue was AC3filter’s SPDIF passthrough.

I ran the "SPDIF configuration" and disabled the passthrough for AC3, DTS and MPEG Audio and that fixed the issue.[/quote]

**CORRECT: SPDIF SHOULD NOT BE ENABLED (unless of course you are using SPDIF - if you don’t know, then you’re not using it :))

This is odd as SPDIF is usually unchecked/disabled from install.

Please ensure you are installing w/this disabled if you have a similar issue.

[quote=“sencer”]OK, just solved the audio issues ! it seems I should have opened tversity via my account, not local system account :D -I thought I’ve done this, but anyways lol-

a new problem : 5.1 … I can not have 5.1 sound while tversity transcodes mkvs. If I turn transcoding off, it plays well, but all we need is transcoding to get all mkv s play.

[b]My ac3 filter’s output format is : PCM16 3/2.1 /b 48000 … 5.1 channel. rate is AS IS.

I’ve researched the forum and found this guy : viewtopic.php?t=5292

What should I do now ?

thanks in advance[/quote]

You just answered your own question. “[your] ac3 filter’s output format is…”

You need your output format to be 5.1 or whatever channel setup you’re looking for

please note: FFDShow also has settings for 2.0, 5.1, etc.

If you are sending a signal that does not include the other channels, PS3 will not upconvert it to 5.1 for you. It will read it as the stream is sent.

also please see future notes regarding FFDShow & AC3.

[quote=“dominatingtnt”]I want to thank u personally! Absolutely brilliant! Followed ur instructions step by step- even the rebooting which was annoying! Bt it workd! Ive tried 4 different versions of nero, wmp, twonky, gore, n many others for the last month and NONE cld transcode RMVB on the fly! But i will say this everything seemed lke it was not working till i did these 2 extra steps-
Stop server. Go to Star/Run and type ‘mediaserver.exe -debug’ let it debug
Then go on your playstation- to network connections and select easy and just reset ur connections- im using LAN line!
FINALLY i cn watch season 1-4 of boston legal using my ps3 on the tv thank u![/quote]

PLEASE DO NOT LISTEN TO THIS GUY. I’m glad it worked for you. But DO NOT RUN THE DEBUG. Its unnecessary and can have various results depending on your system.

You’re missing the forest for the trees:

This is a bandwidth limitation, not a processing limitation.

The PS3 can accept about an 8.5 MB/s stream.

Transcoding at a rate that maintains an "HD" frame rate means that the packet size and therefore required buffer size is too big for the PS3 because it tops a minimum of 10 MB/s.

Simple bandwidth, that’s it.