Unwanted cropping & zooming with DVR-MS files ONLY

I have run a few tests on this to see if its just me, my HR20, or just DVR-MS files and have determined that it is ONLY DVR-MS files.

No matter where I play the video (meaning on my XBOX 360, HR20-700, or the TVersity application within Windows itself) the video is ALWAYS zoomed in and cropped to where you can’t watch it. I have brought this up before, but no solution has been found yet.

Imagine putting two strings on your TV where they cross in the middle. This would give you 4 distinct areas (quadrants if you will). Now, imagine the show you are wanting to watch being only shown from that 1st quadrant on the screen (it is zoomed in to the upper left area with nothing else of the picture being shown). This is what is happening.

First I tried it on my HR20-700 with avi’s, mpg’s, and DVR-MS files. The DVR-MS files are the only ones that will not play correctly.

Then I tried it on my 360 just to see. Tried the same 3 formats, only the DVR-MS files played back incorrectly.

Finally, I came in to the host computer running TVersity to see what happened there. Tried the same 3 formats, only the DVR-MS performed like this.

Seems to me like more people should be having this problem, but there are so many other problems posted up here, it makes finding a common problem VERY difficult even with search.

I have tried to fix this by going in and changing all kinds of settings in TVersity, but none have made the playback of the DVR-MS files look any different at all.

Can ANYONE please tell me they are having the same problems. Or they HAD the same problems and how they fixed it? Or a developer tell me that they are working on this?

Thanks!

The HR20 only accepts MPEG2 so the ‘zoom’ has to originate on your server.

What is the decoding filter chain being used? If you don’t know download something like graphedit or gspot

graphedit: http://www.digital-digest.com/software/ … id=0&did=1

Also - if I remember correctly - DVR-MS = MPEG in AVI for ffdshow - can you check if MPEG in AVI is selected in ffdshow ? You might try both settings to see if there is any difference.

ok, so, after more testing, its not ALL dvr-ms files, its only HD dvr-ms files. So, there is something with the way tversity is decoding the HD versions of the file that is causing it. All other dvr-ms files that are played back have about the bottom 1/5th of the screen with a big green bar all the way across. The rest of the video is being squished a little bit.

So, it looks like I will just keep using my 360’s media center extender stuff for it cuase I don’t think its anything in the settings. I am using everything default as they come when you install tversity, so if there were a known problem with this, or if anyone else were having the problem, they would have stuff written up on the website or on this forum on how to fix it.

Possibly - the only other thing I can think of is what is actually producing the DVR-MS files ? Maybe there is some setting in it that maybe causing it ?

Its Windows Media Center that creates the files. And occasionally GB-PVR, but it does pretty much the same thing encoding wise as Windows Media Center.

I have GB-PVR setup at home - I am using an HVR-1600 so I can try out mine and see what happens. If I find anything useful I’ll let you.

Make sure in config you have it setup for DVR-MS files instead of the default TS files.

Wow!

So I record 2 minutes of the Fox pre-race show and played it back on the HR20

  1. The playback was not thru FFDShow
    My filter chain is:

DVR_Source_0 --> AC3 Filter --> Default_DirectSound_Device
DVR_Source_0 --> HCW_MPEG_2_Video_Decoder --> Video_Renderer

  1. The audio was fine - but the picture was huge and zoomed into the upper left ‘quadrant’ as you observed

Here is MediaInfo for the original DVR-MS file (720p)

[code]General #0
Complete name : D:\Record\Ch59-1_SunApr272008_011842PM.dvr-ms
Format : Windows Media
File size : 206 MiB
PlayTime : 1mn 59s
Bit rate mode : VBR
Bit rate : 15 Mbps
BitRate_Maximum : 160 Mbps
Encoded date : UTC 2008-04-27 17:18:42.281

Video #0
Codec : MPEG-2 Video
Codec/Family : MPEG-V
Codec profile : Main@High
Codec settings, Matrix : Standard
PlayTime : 1mn 59s
Bit rate mode : CBR
Bit rate : 14 Mbps
Nominal bit rate : 19 Mbps
Width : 1280 pixels
Height : 720 pixels
Display Aspect ratio : 16/9
Frame rate : 59.940 fps
Chroma : 4:2:0
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.251
Language : en-us

Audio #0
Codec : AC3
Bit rate mode : CBR
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Rear: L R, Subwoofer
Sampling rate : 48 KHz
Language : en-us[/code]

Here is the transcoded file MediaInfo

[code]General #0
Complete name : C:\Program Files\TVersity\Media Server\data\2dba11ba-a092-2640-bb08-7fda91365a78.part
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 42.9 MiB
PlayTime : 1mn 21s
Bit rate : 4444 Kbps

Video #0
Codec : MPEG-2 Video
Codec/Family : MPEG-V
Codec profile : Main@Main
Codec settings, Matrix : Standard
PlayTime : 1mn 21s
Bit rate mode : CBR
Bit rate : 3943 Kbps
Nominal bit rate : 15 Mbps
Width : 704 pixels
Height : 480 pixels
Display Aspect ratio : 16/9
Frame rate : 29.970 fps
Chroma : 4:2:0
Interlacement : Progressive

Audio #0
Codec : MPEG-1 Audio layer 2
PlayTime : 1mn 21s
Bit rate mode : CBR
Bit rate : 192 Kbps
Channel(s) : 2 channels
Sampling rate : 48 KHz
Resolution : 16 bits
Video0 delay : 8ms
Writing library : Xing (new)

Menu #0
Codec : DVD-Video[/code]

SEE!!! I am NOT nuts!!! :)

Just wondering, is your tversity set up where the max resolution is 704 x 480 by chance? I figure its not, but thought I might ask. I tried adjusting that myself and didn’t have any difference, but I thought you might have some luck.

Dev’s, if you read this and can figure it out, please develop some kind of fix or workaround for it.

Thanks.

No my max is set to 1280x720
No idea where the 704x480 came from ? I don’t think TVersity should resize it - but by the same token I think the HR20 could do a little better job on the render also - I would think it would scale it to 480p.

Well, again, it is NOT just the HR20. It happens on a XBOX360, PS3, Wii, whatever you throw at it (even another pc). It is the problem of tversity entirely. It is NOT the device it is playing it on. I believe its just simply because tversity doesn’t know how to transcode it properly.

Hi,
We would appreciate it very much if you can perhaps send the sample file to us so we can reproduce this issue.
You can use https://www.transferbigfiles.com/ or any other free file sharing service.

Want circumstantial evidence? Set up WMP11 so it can share your pictures to HR20. Bet it will work perfectly, as it does for me, never misses a picture even when doing a "shuffle all" for your pictures.