WD TV LIVE PLUS - Firmware

Where do I find the XML file to edit???///

In Windows Explorer, go to: C:\Program Files\TVersity\Media Server\profiles.xml

Open profiles.xml in Notepad, find the profile for the WD TV Live and swap out the code as per bmc 123’s instructions. Don’t forget to stop the media server and restart it.

Works for me! Thanks!

Thanks bmc123 for the recommended fix for the profiles file. The only thing I would like to add is the following:
My OS is Windows 7 and I found the profiles file in the following hidden directory: C:\ProgramData\TVersity\Media Server
Also I had to edit the file permissions to allow me to edit the file.

thanks bmc123 - this solved my problem

sharing your expertise with others makes the net a fun experience

regards - john

Check that you are running the latest version of TVersity - the official WDTV profile was added in version 1.9.6(7)

What if WDTV LIVE does not appear in profiles.xml?

What do I do?

I’ve made the suggested changes to the Profile file but it still doesn’t work - I still get the No Media Found message.

I have 2 WDTV Live devices, and the suggested Profile.xml change has allowed me to access tversity from both.

What I have noticed, is that with 1.9.3, I had menus set to CUSTOM, and the following for a config.xml

<index parent="TVersity Folders" props="folder">
<index parent="TVersity" filter="tag = tversity.featured">

<index parent="TVersity Custom.Internet" trigger="TVersity.Video.Internet">
<index parent="TVersity Custom.Internet" trigger="TVersity.Photos.Internet">
<index parent="TVersity Custom.Internet" trigger="TVersity.Audio.Internet">
<index parent="TVersity Custom.Internet" trigger="TVersity.Video.RSS &amp; Podcasts">
<index parent="TVersity Custom.Internet" trigger="TVersity.Photos.RSS">
<index parent="TVersity Custom.Internet" trigger="TVersity.Audio.RSS &amp; Podcasts">

<index parent="TVersity Custom.Folders" trigger="TVersity.Photos.My.All" props="folder">
<index parent="TVersity Custom.Folders" trigger="TVersity.Video.Movies.All" props="folder">
<index parent="TVersity Custom.Folders" trigger="TVersity.Audio.Music.All" props="folder">

Unfortunately, with 1.9.7, when I use this config.xml, I don’t have any folders showing up (either from the WD, or from the Tversity gui, when clicking the Library\Active Menus option. My original goal was such that I would chose “Video->Media Servers->Tversity” from my WD…and the next options would be Internet or Folders (with all the content for either under those 2 options with no other filters etc…). The above config.xml worked with 1.9.3, but not with 1.9.7. Anyone have any ideas?


Thank you for posting this.

This is just to let everyone now that version 2.1 of TVersity supports the latest WDTV firmware.


Waqt News

Awesome!! It’s just what I need!! Thanks!..

Hello everybody. I have a small problem I need help with.

Background–purchased WD TV Live yesterday and updated to v1.12.14. I’m running Tversity 1.97 on an older Dell XP desktop and streaming all my stuff wirelessly downstairs to the WD TV hooked up to an entertainment system. All audio and video is working shockingly well, EXCEPT . . .

Problem–My rather large collection of flac files will not play. Not only does the WD Live not play them, Tversity status shows no entries of the attempt having been made so no error message available to post. (The Xbox 360 I’m hoping to replace as a streaming device plays the flacs from the same computer, same Tversity).

I realize I can roll back the firmware on the WD LIve or pay money and update Tversity to make changes, see if things improve. But before attempting these fixes, I wanted to check to see if anyone has experienced a similar problem and affected a less drastic repair. (Perhaps there’s another small code change in the profile that can be made etc).

Your thoughts greatly appreciated and Happy New Year! :)