Windows Phone 7 Devices


Since downloading TVersity my main objective was to stream media to my Windows Phone 7 Device.
I had a lot of problems, first I couldn’t connect to the server, and then it kept trying to stream in .avi format (which WP7 does not support!)

However after fine tuning my settings, I can now watch movies on my Windows Phone 7 and I have never looked back.

This topic is for the guys who need the settings to stream videos to the device!

So, open the TVersity Media Server GUI.

Click Settings, then the General tab.

Media Playback Device: WMV9 Video Device.

Leave the IP address blank

Make sure you remember your port, or leave it as default (recommended) - 41952

I have turned off HTTP Proxy.

Click on the Transcoder Tab

When To Transcode: Always (Important)

Mine is set to Decrease Bitrate if its too high for my network

Tick Use DirectShow for Windows Media Encoding and click Windows Media Video 9 in the drop down menu

And that is all that should matter.

Then on your WP7 Device, open IE, navigate to http://IP ADDRESS OF MEDIA SERVER:PORT so for example, mine is -

If you do not know your IP address then hit Start > Run and type ‘cmd’
In the little black box type ipconfig and search for your IPv4 address.

Once you are at the TVersity server page navigate to your movies and they should play perfectly fine with Zune.

Any issues, please post here.

Hello, i have been trying to find a way to stream my media either over my network or over the net. I found your app via google, and was realy impressed. I have followed your directions to the T, and i still cant get my movies to play. I have roughly about 1100 movies, 99% of wich are in .avi format. I just recently purchased a samsung focus, wp7. I am trying to access the movies and find the title i want to watch, and click on it and after a second or two, i get the CANNOT PLAY THIS BLA BLA WINDOWS PHONE CANT PLAY THIS FORMAT .MPG crap. Using your directions i couldnt get any of the titles to play. If you need me to provide any more information i can, just ask. Thanks in advance. :)

Update: Scratch that, i messed with it more and snafu’ed something. It is now working.
Here are my settings.
I have http checked and then on transcode, i chose wmv 7 instead of 9. i waited about ten min and it is now working.

Thanks for this usefull info. Mad props on this vega!

It is indeed transcoding.

I tried switching transcoding off and viewing a WMV file, and still couldn’t seem to seek at all.

It’s a real shame that there’s no way to set the playback start position in TVersity, even if I can’t interactively seek. Without this it’s pretty much unusable, which is a shame as it’s so close…

Hey guys, sorry for not replying. I was away for a while :) glad you got it sorted though, was gonna suggest changing to windows media 7 :)

Version 1.9.6 should provide a built in profile for WP7 devices now, so you should get transcoding of all non native video. Maybe check to make sure your browser is set to display the desktop version of sites.

The auto-detection of the browser is also broken with Mango as the browser strings changed radically.

Is TVersity transcoding? The Status page in the GUI should tell you. Transcoding is almost guaranteed to kill FF/RW/skip on any device.

WMV might not need transcoding, so maybe if you got one of those to test with things MIGHT be different, although you’d have to convert to WMV for any long-term gain in functionality…

Many thanks for this guide, very useful.

I also found that my Windows Firewall settings prevented me from accessing the TVersity server. I could access it fine in a browser on the PC itself, but not on my WP7 device. I cured this by going into the Windows Firewall control panel, selecting "Allow a program or feature through Windows Firewall" and then checking the "Home/Work (Private)" box for the TVersity Media Server program (previously this was unchecked).

The results are nearly perfect: all my videos are available, the browser is responsive and easy to use, the videos play perfectly and at great quality.

Why only “nearly”? I can’t find any way to seek forwards or backwards through the video stream. Even being able to manually set a start point (in minutes:seconds) would suffice. Without that, the only option is to watch the video from the beginning. If I have any interruptions, I have to start all over again. This is a major issue for me unfortunately. :( Does anyone have any suggestions as to how to overcome this problem?



What model phone do you have? Did you check the manual or Google for media types it can play?

I would expect that a Windows device would be more advanced, and not playing WMV natively sounds odd. Make sure you completely disable transcoding, at the GUI level and each folder in the Library (Advanced button when editing the folder settings), and try WMV again…

Hello I am also having the issue where I can’t play any video and I get the error message that it doesn’t recognize .mpg files.

I have tried switching to wmv 7 as stated earlier and I am still getting the same message.

Any advice would be greatly appreciated.

You should set vpn between you home network and the target device.
When you turn on you vpn you can stream as you connected to you home network.

I am trying to stream media va the 4G network without having to be on my network at home to view videos from my computer. Is there a way to do this over the cell towers? Thanks in advance.

Thanks for sharing these instructions here at

I found out windows phones to be much more complicated than the Android one’s. Their navigation style is totally different & awkward.

I found this post earlier today while in the office Very useful Sent the link to myself and will most likely bookmark when I make it home Wonderful!

I have not checked in here for a while as I thought it was getting boring, but the last few posts are good quality so I guess I will add you back to my daily phorumlist. You deserve it my friend :) good luck

The results are nearly perfect: all my videos are available, the browser is responsive and easy to use, the videos play perfectly and at great quality.